Discussion:
Arbeitsfläche einrichten defekt
(zu alt für eine Antwort)
Hans-Dieter Schulze
2018-05-04 17:29:07 UTC
Permalink
Hallo,

beim Versuch ein anderes Hintergrundbild für den Desktop über
"Arbeitsfläche einrichten" zu wählen, wird der Dialog "Einstellungen für
Arbeitsfläche - Plasma" mit der Meldung "Layout-Änderungen müssen
angewendet werden, bevor eine weitere Bearbeitung möglich ist" angezeigt.
Die Schaltfläche "Jetzt anwenden" behebt das Problem nicht.

Dieses Verhalten tritt auch bei einem neu angelegten Benutzer auf.
Kennt jemand eine Lösung?

Gruß Hans-Dieter
--
OS: openSUSE Tumbleweed · Kernel: 4.16.5-1-default
KDE: 4.14.38 · Plasma: 5.12.4
Dieter Intas
2018-05-04 17:56:29 UTC
Permalink
Am Fri, 4 May 2018 19:29:07 +0200
Post by Hans-Dieter Schulze
Hallo,
beim Versuch ein anderes Hintergrundbild für den Desktop über
"Arbeitsfläche einrichten" zu wählen, wird der Dialog "Einstellungen
für Arbeitsfläche - Plasma" mit der Meldung "Layout-Änderungen müssen
angewendet werden, bevor eine weitere Bearbeitung möglich ist"
angezeigt. Die Schaltfläche "Jetzt anwenden" behebt das Problem nicht.
Richtig - bei: Layout: Ordner-Ansicht geht es aber!
Hans-Dieter Schulze
2018-05-09 17:24:11 UTC
Permalink
Post by Dieter Intas
Am Fri, 4 May 2018 19:29:07 +0200
Post by Hans-Dieter Schulze
Hallo,
beim Versuch ein anderes Hintergrundbild für den Desktop über
"Arbeitsfläche einrichten" zu wählen, wird der Dialog "Einstellungen
für Arbeitsfläche - Plasma" mit der Meldung "Layout-Änderungen müssen
angewendet werden, bevor eine weitere Bearbeitung möglich ist"
angezeigt. Die Schaltfläche "Jetzt anwenden" behebt das Problem nicht.
Richtig - bei: Layout: Ordner-Ansicht geht es aber!
Hallo Dieter,

ja genau da komme ich aber nicht hin.
Unter Hintergrundbild fehlen die Punkte Layout, Hintergrundbild-Typ und
Positionierung. Es wird nur die Fehlermeldung aus meinem ersten Posting
angezeigt.
Meine Signatur war übrigens fehlerhaft.

Gruß Hans-Dieter
--
OS: openSUSE Tumbleweed · Kernel: 4.16.5-1-default
Qt: 5.10.0 · Plasmashell: 5.12.4
KDE Frameworks: 5.45.0 · KDE Applications: 18.04.0
Dieter Intas
2018-05-10 06:50:16 UTC
Permalink
Am Wed, 9 May 2018 19:24:11 +0200
Post by Hans-Dieter Schulze
Post by Dieter Intas
Am Fri, 4 May 2018 19:29:07 +0200
Post by Hans-Dieter Schulze
Hallo,
beim Versuch ein anderes Hintergrundbild für den Desktop über
"Arbeitsfläche einrichten" zu wählen, wird der Dialog
"Einstellungen für Arbeitsfläche - Plasma" mit der Meldung
"Layout-Änderungen müssen angewendet werden, bevor eine weitere
Bearbeitung möglich ist" angezeigt. Die Schaltfläche "Jetzt
anwenden" behebt das Problem nicht.
Richtig - bei: Layout: Ordner-Ansicht geht es aber!
Hallo Dieter,
ja genau da komme ich aber nicht hin.
Wie du schon sagtest: Arbeitsfläche einrichten defekt!
Post by Hans-Dieter Schulze
Unter Hintergrundbild fehlen die Punkte Layout, Hintergrundbild-Typ
und Positionierung. Es wird nur die Fehlermeldung aus meinem ersten
Posting angezeigt.
Mausklick auf Desktop rechts - mit dem Mauszeiger auf "Arbeitsfläche
einrichten" und nun Alt+D drücken. Nun erscheint der Displaymanger, also
Passwort eingeben und Return.

Wenn du nun die Arbeitsfläche einrichten und den Dialog Hintergrundbild
betrachtest, hat sich dann was geändert bzw. ist der Dialog nun vollständig,
also Auswahl:

Layout: Arbeitsfläche
Ordner-Ansicht

vorhanden und du kannst (wie üblich) auswählen und dann das
Hintergrundbild einrichten?
Post by Hans-Dieter Schulze
Meine Signatur war übrigens fehlerhaft.
Es ist durchaus möglich KDE: 4.14.38 · Plasma: 5.12.4 zu installieren -
ob es denn auch funktioniert ist eine andere Sache.

Ist da möglicherweise noch ein Kde4 Paket installiert und dieses dann
Plasma in die Quere kommt?
Hans-Dieter Schulze
2018-05-11 18:04:17 UTC
Permalink
Hallo Dieter,
Danke für Deine Hinweise.
Post by Dieter Intas
Mausklick auf Desktop rechts - mit dem Mauszeiger auf "Arbeitsfläche
einrichten" und nun Alt+D drücken. Nun erscheint der Displaymanger, also
Passwort eingeben und Return.
Bei Alt+D passiert nichts.
Post by Dieter Intas
Wenn du nun die Arbeitsfläche einrichten und den Dialog Hintergrundbild
betrachtest, hat sich dann was geändert bzw. ist der Dialog nun vollständig,
Layout: Arbeitsfläche
Ordner-Ansicht
vorhanden und du kannst (wie üblich) auswählen und dann das
Hintergrundbild einrichten?
An Layout: Arbeitsfläche komme ich über diesen Weg nicht ran.
Post by Dieter Intas
Es ist durchaus möglich KDE: 4.14.38 · Plasma: 5.12.4 zu installieren -
ob es denn auch funktioniert ist eine andere Sache.
Bei mir läuft KDE 5.45.0, siehe Signatur
Post by Dieter Intas
Ist da möglicherweise noch ein Kde4 Paket installiert und dieses dann
Plasma in die Quere kommt?
Ja, es gibt kde4-Pakete
tw:~ # zypper se -i kde4
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
---+-----------------------+-----------------------------------+--------
i+ | kde4-filesystem | KDE4 Directory Layout | package
i+ | kde4-kgreeter-plugins | The KDE Greeter Plugin Components | package
i+ | libkde4 | KDE Base Libraries | package
i+ | libreoffice-kde4 | KDE4 interface for LibreOffice | package

Ob ich diese entfernen oder ersetzen kann, muss ich in den nächsten
Tagen prüfen.

Gruß Hans-Dieter
--
OS: openSUSE Tumbleweed · Kernel: 4.16.5-1-default
Qt: 5.10.0 · Plasmashell: 5.12.4
KDE Frameworks: 5.45.0 · KDE Applications: 18.04.0
Martin Schnitkemper
2018-05-12 18:06:06 UTC
Permalink
Post by Hans-Dieter Schulze
Post by Dieter Intas
Mausklick auf Desktop rechts - mit dem Mauszeiger auf "Arbeitsfläche
einrichten" und nun Alt+D drücken. Nun erscheint der Displaymanger, also
Passwort eingeben und Return.
Bei Alt+D passiert nichts.
Kann auch nicht, weil das nur in Verbindung mit einem weiteren Hotkey
funktioniert, z.B. Alt+S.

Nur bringt dich das nicht weiter, weil ja der Aufruf nicht das Problem ist,
sondern dass die Dialoge für die Konfiguration der Arbeitsfläche nicht
erscheinen. Und da ist es auch egal, ob man das über die Menüstruktur oder
einen Hotkey aufruft.
Post by Hans-Dieter Schulze
S | Name | Summary | Type
---+-----------------------+-----------------------------------+--------
i+ | kde4-filesystem | KDE4 Directory Layout | package
i+ | kde4-kgreeter-plugins | The KDE Greeter Plugin Components | package
i+ | libkde4 | KDE Base Libraries | package
i+ | libreoffice-kde4 | KDE4 interface for LibreOffice | package
Ob ich diese entfernen oder ersetzen kann, muss ich in den nächsten
Tagen prüfen.
Kann zypper auch nach verwaisten Paketen suchen? Dann wüsste man, ob diese
Pakete überhaupt noch von irgendeinem anderen Paket benötigt würden. Oder
sich die Abhängigkeiten dieser Pakete ansehen, ob die noch von irgendeiner
Plasma-5-Komponenten verwendet werden.
--
powered by Arch Linux x86_64
Kernel: 4.16.6-1-ARCH · KDE 5.12.5 · KF 5.45.0
Martin Schnitkemper
2018-05-05 17:06:20 UTC
Permalink
Post by Hans-Dieter Schulze
beim Versuch ein anderes Hintergrundbild für den Desktop über
"Arbeitsfläche einrichten" zu wählen, wird der Dialog "Einstellungen für
Arbeitsfläche - Plasma" mit der Meldung "Layout-Änderungen müssen
angewendet werden, bevor eine weitere Bearbeitung möglich ist" angezeigt.
Die Schaltfläche "Jetzt anwenden" behebt das Problem nicht.
Kann ich hier nicht nachvollziehen. Diese Meldung bekomme ich nur, wenn
ich zwischen den Layouts "Ordner-Ansicht" und "Arbeitsfläche" wechseln
möchte. Die Hintergrundbilder kann ich jederzeit und sofort wechseln, ohne
dass noch eine Nachricht zu beantworten wäre.
Post by Hans-Dieter Schulze
KDE: 4.14.38 · Plasma: 5.12.4
Was ist das denn für ein Mischmasch? KDE4 mit Plasma 5? Das passt irgendwie
gar nicht zusammen.
Post by Hans-Dieter Schulze
Kennt jemand eine Lösung?
Vielleicht erst mal alles auf den aktuellen Versionsstand bringen.
--
powered by Arch Linux x86_64
Kernel: 4.16.5-1-ARCH · KDE 5.12.4 · KF 5.45.0
Hans-Dieter Schulze
2018-05-09 17:12:49 UTC
Permalink
Post by Martin Schnitkemper
Post by Hans-Dieter Schulze
beim Versuch ein anderes Hintergrundbild für den Desktop über
"Arbeitsfläche einrichten" zu wählen, wird der Dialog "Einstellungen für
Arbeitsfläche - Plasma" mit der Meldung "Layout-Änderungen müssen
angewendet werden, bevor eine weitere Bearbeitung möglich ist" angezeigt.
Die Schaltfläche "Jetzt anwenden" behebt das Problem nicht.
Kann ich hier nicht nachvollziehen. Diese Meldung bekomme ich nur, wenn
ich zwischen den Layouts "Ordner-Ansicht" und "Arbeitsfläche" wechseln
möchte. Die Hintergrundbilder kann ich jederzeit und sofort wechseln, ohne
dass noch eine Nachricht zu beantworten wäre.
Post by Hans-Dieter Schulze
KDE: 4.14.38 · Plasma: 5.12.4
Was ist das denn für ein Mischmasch? KDE4 mit Plasma 5? Das passt irgendwie
gar nicht zusammen.
Post by Hans-Dieter Schulze
Kennt jemand eine Lösung?
Vielleicht erst mal alles auf den aktuellen Versionsstand bringen.
Oh,
meine Signatur war fehlerhaft.
Das konnte früher mit knode nicht passieren, wo die Signatur über ein
Skript erzeugt wurde.
Es ist also kein Mischmasch.

Gruß Hans-Dieter
--
OS: openSUSE Tumbleweed · Kernel: 4.16.5-1-default
Qt: 5.10.0 · Plasmashell: 5.12.4
KDE Frameworks: 5.45.0 · KDE Applications: 18.04.0
Hans-Dieter Schulze
2018-09-07 17:47:32 UTC
Permalink
Post by Hans-Dieter Schulze
Hallo,
beim Versuch ein anderes Hintergrundbild für den Desktop über
"Arbeitsfläche einrichten" zu wählen, wird der Dialog "Einstellungen für
Arbeitsfläche - Plasma" mit der Meldung "Layout-Änderungen müssen
angewendet werden, bevor eine weitere Bearbeitung möglich ist" angezeigt.
Die Schaltfläche "Jetzt anwenden" behebt das Problem nicht.
Dieses Verhalten tritt auch bei einem neu angelegten Benutzer auf.
Kennt jemand eine Lösung?
Gruß Hans-Dieter
Ich antworte, auch nach so langer Zeit, mal selbst, da ich im Internet
einige andere Nutzer mit diesem Problem gefunden hatte.

Nach dem Beenden von Plasmashell und Start auf der Kommandozeile wurden
Fehler ausgegeben, die auf Unstimmigkeiten in /usr/share/plasma hinwiesen.
Ich habe dieses Verzeichnis auf einer virt. Maschine gesichert und
eingespielt. Nun ist alles OK.
Wie das passieren konnte, kann ich nicht sagen. Änderungen habe ich nie
als root ausgeführt.

Gruß Hans-Dieter

-- OS: openSUSE Tumbleweed · Kernel: 4.18.5-1-default
Qt: 5.11.1 · Plasmashell: 5.13.4
KDE Frameworks: 5.49.0 · KDE Applications: 18.08.0

Loading...